提供: EELの自由帳
移動先: 案内検索

Ruby 2.5 をインストール(CentOS8)

メインページ > CentOS_8_で自宅サーバー構築  > Ruby 2.5 をインストール(CentOS8)

  • 自宅サーバーで、動作確認しています。導入される方は自己責任で行ってください。

CentOSバージョン確認

[root@host3 ~]# cat /etc/redhat-release
CentOS Linux release 8.1.1911 (Core)

インストール

有効になっている Ruby のバージョンを確認

[root@host3 ~]# dnf module list ruby

Name            Stream             Profiles              Summary                                                        
ruby            2.5 [d]            common [d]            An interpreter of object-oriented scripting language           
ruby            2.6                common                An interpreter of object-oriented scripting language=== Stream切り替え ===

Ruby 2.5 を指定してインストール

[root@host3 ~]# dnf module -y install ruby:2.5

依存関係が解決しました。
========================================================================================================================
 パッケージ                   Arch           バージョン                                         リポジトリー      サイズ
========================================================================================================================
group/moduleパッケージをインストール:
 ruby                         x86_64         2.5.5-105.module_el8.1.0+214+9be47fd7              AppStream          86 k
依存関係のインストール:
 ruby-irb                     noarch         2.5.5-105.module_el8.1.0+214+9be47fd7              AppStream         102 k
 ruby-libs                    x86_64         2.5.5-105.module_el8.1.0+214+9be47fd7              AppStream         2.9 M
 rubygem-json                 x86_64         2.1.0-105.module_el8.1.0+214+9be47fd7              AppStream          90 k
 rubygem-psych                x86_64         3.0.2-105.module_el8.1.0+214+9be47fd7              AppStream          95 k
弱い依存関係のインストール:
 rubygem-bigdecimal           x86_64         1.3.4-105.module_el8.1.0+214+9be47fd7              AppStream          97 k
 rubygem-did_you_mean         noarch         1.2.0-105.module_el8.1.0+214+9be47fd7              AppStream          90 k
 rubygem-io-console           x86_64         0.4.6-105.module_el8.1.0+214+9be47fd7              AppStream          66 k
 rubygem-openssl              x86_64         2.1.2-105.module_el8.1.0+214+9be47fd7              AppStream         190 k
 rubygem-rdoc                 noarch         6.0.1-105.module_el8.1.0+214+9be47fd7              AppStream         486 k
 rubygems                     noarch         2.7.6.2-105.module_el8.1.0+214+9be47fd7            AppStream         308 k
モジュールプロファイルのインストール:
 ruby/common                                                                                                           
モジュールストリームの有効化:
 ruby                                        2.5                                                                       

トランザクションの概要
========================================================================================================================
インストール  11 パッケージ

Ryby バージョン確認

[root@host3 ~]# ruby -v
ruby 2.5.5p157 (2019-03-15 revision 67260) [x86_64-linux]